DXF 和 DWG 文件
DXF 是几乎所有 CAD 程序都能读写的图纸格式;DWG 是 AutoCAD 自己的格式。使用 文件 › 导入 › 导入… 可以导入这两种文件,使用 文件 › 导出 › 导出… 并选择 AutoCAD 文件 可以保存 DXF。直线、圆弧、曲线、文字、光栅图像、填充图案和尺寸标注都会转换。
导入的图纸常常有重复绘制的线,或差一点没有相接的线:编辑 › 清理图纸… 可在切割前修正这些问题(参见清理图纸)。
图层
刀模制作图纸的图层说明每条线是什么:切割线、压痕线、打孔线等。导入 DXF 时,每个 DXF 图层按其名称放到 ParametrIQ CAD 的某个图层上:
| DXF 图层名称类似 | 放到 |
|---|---|
| CUT-CREASE、CUTCREASE、COMBI | 切压线 |
| REVERSE… | 反向压痕线 |
| PERF… | 打孔线 |
| PARTIAL…、HALF CUT、KISS、CUTSCORE | 半切线 |
| CREASE、SCORE、FOLD、RILL | 压痕线 |
| V-CUT、VCUT、GROOVE | V 形切割 |
| GLUE、TAPE | 胶带 |
| DIM…、ANNOT…、NOTE…、TEXT… | 尺寸标注 |
| CUT、KNIFE | 切割线 |
名称只需包含该词即可(KNIFE_2PT 是切割线),且不区分大小写,但 V-CUT 和 VCUT 必须是完整名称。规则从上往下依次尝试,因此 CUT-CREASE 是切压线而不是切割线。
ParametrIQ CAD 自己的图层名称(Cut、Crease、Partial Cut……)以及 DDES3 和 CF2 线型图层(DDES3 201、CF2 41……)始终会回到相同的图层,因此您导出的 DXF 可以精确地读回。
其他任何 DXF 图层都保留其自己的名称和颜色:作为单独的图层添加到图层表中。如果一个 DXF 图层中有多种颜色或线型的线条,则每种各有一个以其命名的单独图层(例如 Stuff (#FF0000))。
填充区域(填充图案和实体)的轮廓只放到胶带图层上;否则保留在单独的图层上,因此填充区域永远不会变成切割线。
您自己的规则
每个刀模制作商对图层的命名都不同。您可以在应用程序数据的 PiQ 文件夹中名为 dxf-layers.txt 的文本文件里添加自己的规则(在 Windows 上为 %APPDATA%\PiQ\dxf-layers.txt)。您的规则会先于上述规则尝试,除非在导入选项中关闭 使用我的图层规则。每行一条规则:
# comments start with #
KNIFE* = Cut
*RILL* = Crease
MATRIX* = CF2 40
COUNTER* = DDES3 201
TABLE* = keep (its own layer, whatever the rules below say)
colour 1 = Crease
colour 5 = Perforation
- 名称使用通配符:
*表示任意一串字符,?表示任意一个字符。不区分大小写。 - colour n 在没有名称规则匹配时,匹配实体(或其图层)的 AutoCAD 颜色索引。
- 目标:Cut、Crease、Partial Cut、Perforation、Tape、Dimension、Reverse Crease、Cut Crease、V-Cut、
DDES3 n或CF2 n(该刀模制作线型的图层),或 keep 表示单独的图层。 - 目标后括号中的文字是注释,会被忽略。
ParametrIQ CAD 无法读取的规则会在导入后的消息中列出。
尺寸标注
线性、对齐、角度、半径、直径和坐标尺寸标注会作为 ParametrIQ CAD 尺寸标注读入到其点上,因此更改图纸时它们会随之变化。其文字高度、箭头大小、间隙、小数位数以及任何自定义文字都从 DXF 标注样式中转换过来。
在导入选项中关闭 尺寸标注作为尺寸标注,可改为以其线条和文字导入;如果同时关闭 其他尺寸标注的线条,则不导入。
导出时,尺寸标注同样写为 DXF 尺寸标注(垂直尺寸标注写为对齐尺寸标注),每个都带有表示其尺寸的标注样式,以及由 ParametrIQ CAD 绘制的线条和文字组成的块,因此其他程序显示的内容与您看到的完全相同。在导出选项中关闭 尺寸标注作为 DIMENSION,可将其写为线条和文字。
填充图案和填充
从 DXF 读取的填充图案以其轮廓(位于填充图案图层上的隐藏图元)为边界,作为填充导入:图案填充按其角度和间距导入为填充线,实体填充以其颜色(及其透明度)导入,渐变填充导入为渐变(线性、圆柱、球形、半球形和曲线,以及它们的反转形式)。在导入选项中关闭 填充 可不导入它们。填充图案线(默认关闭)会同时导入填充图案中的每条线,合并填充边界(默认开启)会使每个边界成为一个闭合轮廓。
导出时,填充写为 HATCH:填充线写为用户定义的图案,实心填充写为其颜色的实体填充图案,渐变写为最接近的 DXF 双色渐变(径向渐变写为球形;锥形和四角渐变写为其颜色之间的线性渐变)。填充中的孔是填充图案的内边界。渐变只在 ASCII DXF 中保留:二进制 DXF 将其写为纯色。
其他会转换的内容
- 几何图形:直线、圆弧、圆、椭圆、样条曲线和多段线(及其凸度)在任何平面中都精确转换。
- 块以零件导入:每个以实际尺寸放置其块(在图纸平面内旋转和平移)的 INSERT 都成为位于插入点、按插入的旋转角度旋转、位于插入所在图层的零件;插入其他块的块将它们作为其内部的零件,MINSERT 阵列的每个副本各成为一个零件。缩放或镜像其块的插入则改为就地绘制,按图纸所述进行缩放和镜像。如果在导入选项中关闭 块作为零件,则所有块都就地绘制;嵌套深度超过 最大块嵌套深度(16)的块不导入。导出时,每个零件的图纸写为一个块且只写一次(其共享变量使用本图纸的值),每个零件写为它的一个 INSERT。零件中的零件即块插入块。在导出选项中关闭 零件作为块,可将它们就地绘制写入。
- 线型和线宽:图层的虚线样式成为线型,线宽成为线宽(DXF 最宽为 2.11 mm),双向转换。
- 文字(TEXT、MTEXT 和块属性)以文字形式导入,保留字体、对齐方式和格式,并写回为 TEXT,多行时写为 MTEXT,或者使用 文字转为轮廓 写为其字母的轮廓。
- 光栅图像从其文件中读取,文件位置按图纸中的命名查找,或在图纸所在文件夹中查找。DXF 将图像保存在单独的文件中,因此导出时每个图像都写在 DXF 旁边,并以其命名(Box_1.png、Box_2.jpg……),除非在导出选项中关闭 光栅图像。
- 单位:图纸的单位($INSUNITS)会转换为您的单位。导出时使用您图纸的单位。
- 版本:导出为 AutoCAD 2013 DXF,除非在导出选项中选择其他版本(2000、2004、2007、2010、2013 或 2018),格式为 ASCII,或者开启 二进制 DXF 时为二进制。由直线和圆弧组成的形状各写为一个 LWPOLYLINE,除非关闭 多段线作为 LWPOLYLINE。
- 隐藏的图层和实体:关闭或冻结的图层以单独的隐藏图层导入(从不映射到切割线、压痕线……),或者开启 忽略隐藏图层 时不导入;设置为不打印的图层导入后不绘图输出。不可见的实体以隐藏图元导入。可以在图层和属性面板中显示它们。
- 默认不导入(除非在导入选项中开启):图纸空间和引线。二维实体、三维面(其可见边,从上方看)和多线默认导入,除非关闭。
- 始终不导入:射线,以及 ParametrIQ CAD 没有对应图元的内容(三维实体、网格)。导入后的消息会说明哪些内容未导入。
来自数字化仪的石材样板
来自数字化仪(Prodim Proliner、Laser Products LT-55 和 LT-2D3D …)的台面样板也是 DXF:请改用 文件 › 导入 › 导入石材样板… 将其导入,它会把其中的线条连接成工件和开孔,并从图层中读取各边的边型。参见来自数字化仪的石材样板。