页面
一个图纸可以有多个页面:一个页面放刀模线,另一个放其图稿,第三个放其排样。每个页面都有自己的图元和自己的点;图纸的变量、函数、注释、图层和零件由所有页面共享,因此每个页面都遵循相同的尺寸。更改 L,每个页面都会随之改变。
各页面的点
每个页面的点都属于该页面自己,并单独编号:一个页面上的 P5 和另一个页面上的 P5 是不同的点,更改其中一个不会影响另一个。新页面以新图纸所具有的点开始:P0 位于原点,P1 至 P3 为 L × W 盒子的其他角点。点面板列出正在处理的页面的点,转到其他页面时会随之变化。
- 在页面之间复制和粘贴。 在一个页面上复制(或剪切)并粘贴到另一个页面的图元,会带上它们所绘制在的点,以及这些点计算所依据的点。如果目标页面没有该编号的点(或有以相同方式计算的点),点会保留其编号;如果目标页面已有另一个该编号的点,则为其指定新编号,粘贴的图元绘制在新编号的点上。在一个页面上剪切、在另一个页面上粘贴,即可将图元移到那里。粘贴到同一页面时,副本绘制在相同的点上。
- 放置、排样和折叠的页面按其自己的点计算:作为零件放置的页面、页面的排样和 3D 页面,都按该页面在其自身页面上的样子显示,与显示它们的页面上的点无关。排样的角点是被排样页面上的一个点:排样工具会将其带到新页面上。
- 由 制作刀模、出血 和其他生产命令创建的页面也有自己的点。
- 跨页面引用图元:另一个页面上图元的偏移或片段(
OFFSET @7,@2,5,0),或其上的一个点(ONELEMENT(@2,0.5)),会按该图元所在页面的点进行计算。 - 由点计算的变量(
GAP=DISTANCE(P4,P5),如测量工具所生成的)使用正在处理的页面的点:在另一个页面上,会根据该页面的P4和P5重新计算。
页面选项卡
图纸下方每个页面都有一个选项卡;正在处理的页面会高亮显示。
- 点击 选项卡即可处理该页面。绘制、选择、编辑、测量和导出的都是该页面的内容。
- + 新建一个页面并切换到该页面。
- 双击 选项卡可重命名。
- 右键单击 选项卡可重命名、删除或新建页面。
- 选项卡多到放不下时,其后的 < 和 >(或鼠标滚轮)可逐个滚动选项卡。
编辑 › 页面 菜单中也有相同的命令:新建页面、重命名页面…、删除页面,以及用于逐页切换的 下一页 (Ctrl+Page Down)和 上一页(Ctrl+Page Up);新建图幅…、编辑图幅… 和 插入字段… 用于创建和修改图幅。
删除页面会移除其上的所有内容(如果页面上有内容,或者该页面被放置在其他页面上,会先询问)。图纸至少保留一个页面。新建、重命名、删除和切换页面都可以撤销;撤销会回到进行更改时所在的页面。
在页面之间共享零件
- 将页面作为零件:按页面名称将一个页面作为 PART 放置到另一个页面上(
PART @5,P10,P11,"Die line")。它显示该页面的当前状态:编辑该页面,所有放置它的地方都会随之改变。放置在自身上的页面不显示任何内容。 - 零件库:作为零件导入的图纸按名称在图纸的库中只保存一份(PARTDEF),并可按该名称放置在任何页面上。
- 排样:排样工具将当前页面排样到一个新页面上,按名称放置该页面,因此编辑页面时排样会随之改变。
重命名页面时,放置该页面的零件和排样中的名称也会随之更改。
图幅
编辑 › 页面 › 新建图幅… 会创建一个页面,在另一个页面周围加上图框(边框和根据图纸内容填写的标题栏),按适合大小或按比例放置,可直接打印:即图幅。编辑其所显示的页面时,图幅会随之更新。编辑 › 页面 › 编辑图幅… 用于更改图幅的页面、比例和图框输入项,插入字段… 用于放置显示图纸信息(标题、备注、比例、第 n 张,共 m 张)的文字。请参阅图幅和图框。
3D 页面
3D › 3D 折叠 会添加一个页面,以 3D 方式显示图纸第一个页面(第一个非 3D 页面)折叠起来的样子,并切换到该页面。 3D 页面上不绘制任何内容:每次切换到它时都会根据其来源页面重新生成,因此它始终显示图纸的当前状态。除折叠外,页面还可以按其图层的深度(带有型腔和开孔的实体)、将零件组装在一起、缠绕和扫掠生成 3D:参见使图纸成为 3D。拖动可旋转视图,使用滑块可折叠和展开。
3D › 构建模式 选择页面生成 3D 的方式:自动,或所勾选的模式(折叠、拉伸、缠绕、扫掠、装配);参见使图纸成为 3D。
3D › 折叠过程 › 折叠顺序 选择移动滑块时折叠的进行方式:
- 自然(通常):与手工成型的方式相同。先竖起侧壁,再折入其上的襟片,然后是封合的面板:先底部后顶部,先折较小的襟片再折覆盖其上的较大襟片,盖子在其覆盖的襟片之后,插舌最后。
- 同时:所有压痕线同时折叠。
- 底部优先:从最靠近底部的面板开始,向外直到末端。
- 末端优先:从末端开始,向内直到底部。
3D › 折叠过程 › 重叠 设置每个步骤与下一步骤的重叠程度:无(依次进行)、少量、 适中(常用) 或 大量(几乎同时)。选择 同时 时该项显示为灰色,因为没有步骤。两项设置都随图纸保存,并可撤销。
3D › 折叠过程 › 折叠步骤 列出各个步骤以及每个步骤中的压痕线。图纸为其指定了步骤的压痕线(
RULE STEP=2,参见 图元设置)会在该步骤折叠,不论折叠顺序如何;其他压痕线按折叠顺序进行。要更改某条压痕线,可在 3D 视图中点击它(它会高亮显示,交互窗口会显示其步骤),然后选择 3D › 折叠过程 › 设置折叠步骤…,或在列表中选中它并选择 设置步骤…:步骤会写入图纸页面中该压痕线的行,作为一个可撤销的步骤;留空则会再次移除。由脚本块生成的压痕线在脚本中指定其步骤。零件组装。 页面上分开的各个展开料各自从其底部折叠起来。带有 MATE 的零件,如果
TO另一个零件(面对面:盒子上的盖子)或IN另一个零件(套中的抽屉),折叠后会与之组装在一起:零件在滑块的前五分之四范围内折叠,最后五分之一将它们组装起来。配合点显示为小箭头(红色表示各自的指向,蓝色表示其内部)。3D › 折叠过程 › 播放步骤 从平面状态开始逐步折叠设计,每步之后暂停;点击视图或移动滑块即可停止。
3D › 折叠过程 › 在 3D 中调整 在 3D 页面上修改图纸,并在修改的同时显示模型的变化(视图工具栏上的 变量、时间轴 和 手动折叠 按钮也可以):视图旁的 变量面板 设置图纸的带标签变量,图纸将变量限定在某个范围内时显示滑块;手动折叠 让您拖动面板将其折叠,并把角度写在其压痕线上(
RULE FOLD=120);视图下方的 折叠时间轴 以条带形式显示各步骤,将压痕线拖到另一个步骤,或将步骤拖到另一个位置,就会写入步骤(RULE STEP=2)。每次修改都是一个可撤销的步骤。参见3D 中的实时编辑。3D › 材料 从可用的材料(外观)中选择其制作材料,按类别分组:服装与纺织、瓦楞、金属、卡纸、塑料与橡胶、硬纸板和木材。自动(根据图纸的材料) 会根据图纸自身的材料进行选择(其
T选择项,或标签为 Material、Fabric、Board 或 Sheet 的选择项)。该选择随图纸保存,并可撤销。外观从扩展文件夹的 Appearances 文件夹中读取;可使用 文件 › 扩展 › 外观… 修改它们或创建您自己的外观(参见外观)。3D › 模型和产品 › 导入模型… 将 3D 模型与折叠后的图纸一起显示(例如纸盒中的瓶子),模型立于其底面板上:支持 glTF(
.glb、.gltf)、OBJ(含其.mtl颜色和纹理)、STL、PRC、U3D 或 COLLADA(.dae,或压缩的.zae)文件。glTF 以米为单位读取,STL 以毫米为单位, OBJ 以毫米为单位,除非其尺寸小于 10 个单位(此时以米为单位),PRC 和 U3D 按其自身说明的单位读取(未说明单位的 U3D 文件按 OBJ 的方式读取),COLLADA 则按其说明的单位和向上轴读取。对话框可接受文件或网址,嵌入图纸(除非取消勾选,否则为勾选状态)会将模型保存在图纸内部(.gltf、.obj 或 .dae 会作为一个 .glb 保存,不含其纹理);取消勾选时,图纸只保存其路径或网址,并在每次打开时读取,因此请勿移动它(请参阅链接的文件和网址)。 3D › 模型和产品 › 移除模型 可将其再次移除。3D › 模型和产品 › 放置产品…、泡棉中的产品型腔… 和 显示产品适配… 将产品的模型放入图纸本身,使其立在折叠后的纸盒或泡棉中,检查其适配,并为其切出泡棉型腔(参见包装中的产品)。
3D › 模型和产品 › 减去模型 会按当前的折叠状态,在模型穿过折叠图纸的位置切出孔。每个面板都被视为位于其外表面的平板,模型穿过之处,会在图纸页面的切割图层上切出与该处模型形状相同的孔,因此 3D 页面会随之折叠。只压入纸板内侧、未到达其外侧的模型不会切出任何孔。跨越压痕线的孔是一个孔,位于两个面板上。该操作是一个可撤销的步骤。以下情况会被忽略并给出提示:
- 会碰到切割边缘或已有孔的切割(它们会切掉一块或改变轮廓,而不是形成孔):请移动模型,或自行切割;
- 弯曲的面板(沿曲线压痕弯曲),它们不是平的;
- 模型不是封闭实体之处。
孔绘制在新点上,因此图纸尺寸变化时它们保持原位。如果模型的截面本身带孔(例如管子),则切出的孔为其完整外轮廓。
3D › 导出 › 导出校样图像… 和 3D › 导出 › 导出校样视频… 为不愿打开 3D 文件的用户生成 3D 页面的图像和视频:每个视图(正面、背面、左侧、右侧、顶部、四分之三视角、带图稿的平面刀模线、当前视图)为 PNG 或 JPEG,或全部放在一张缩略图总览上(图像或 PDF 页面),并带有说明条;以及转台旋转或折叠过程的 MP4、动画 WebP 或 GIF,或 PNG 帧。请参阅校样图像和视频。
3D › 导出 › 导出 3D 模型… 将 3D 页面按显示的样子(当前的折叠程度,包含其模型)写为 glTF (
.glb,或内含数据的.gltf)、OBJ(含其颜色的.mtl)、STL 或 COLLADA(.dae,或压缩的.zae),无论图纸单位如何均以毫米为单位。 glTF 以米为单位、Y 轴向上写入,OBJ 以毫米为单位、Y 轴向上,STL 和 COLLADA 以毫米为单位、Z 轴向上,符合其他程序的预期;glTF、OBJ、STL 和 COLLADA 都可以用 导入模型… 读回。glTF 中每个面板为一个部件,在其压痕线处与其折叠所依附的面板铰接,折叠过程为动画 Fold 和 Unfold,材料及图稿(和烫金)为纹理;OBJ 中外侧、内侧和切割边缘各为一个部件,图稿为旁边的 PNG 图像;STL 没有颜色。请参阅 glTF、OBJ 和 STL 以及 COLLADA。关于 Cape Pack,请参阅 Cape Pack 和 TOPS Pro。PRC(.prc,用于 3D PDF)写出时每个面板为一个部件,放在显示的位置,图稿为纹理;也可以读回。请参阅 PRC。U3D(.u3d)写出时每个面板为一个部件,折叠过程为其动画,图稿为纹理,以毫米为单位、Z 轴向上;也可以读回。请参阅 U3D。 USDZ(.usdz)为 iPhone 和 iPad 上的 AR 快速查看而写出,以米为单位、Y 轴向上,每个面板为一个部件。请参阅 iPhone 和 iPad 上的 AR 校样。文件 › 导出 › 导出校样 (HTML)…(3D 菜单中也有)将 3D 页面写为一个 HTML 文件,用于发送审批:它可在任何网页浏览器中离线打开,包含可旋转和缩放的 3D 查看器中的模型、可播放、暂停和拖动的折叠过程、手机和平板电脑上的增强现实、浅色或深色背景、保存图片和打印功能,以及您所选择的标题、尺寸、材料、分类和备注。请参阅 HTML 校样。
文件 › 导出 › 导出 3D PDF…(3D 菜单中也有)将 3D 页面写为一个以 3D 形式带有模型的 PDF 页面:Adobe Acrobat 和 Reader 可以显示它,供旋转和缩放,并在打开页面时折叠成形;其他 PDF 查看器则显示其图片。请参阅 3D PDF。
3D › 导出 › iPhone 和 iPad 的 AR 校样… 将 3D 页面写为一个 USDZ 文件,从平面折叠成形后保持折叠状态:在 iPhone 或 iPad 上轻点它,AR 快速查看会播放折叠过程,并将包装按实际大小立在桌面或地面上。请参阅 iPhone 和 iPad 上的 AR 校样。
3D › 显示 › 显示地面 打开或关闭地面及其上的阴影。与渲染器一样,这是应用的设置。折叠永远不会使模型陷入地面:当某部分折叠到展开料原先所在位置的下方时,整个模型会被抬起立于地面上,展开时再放回原处。
3D › 显示 › 渲染器 选择绘制所用的图形接口:Direct3D 11(仅限 Windows)、OpenGL 或 Vulkan。这是应用的设置,用于所有 3D 页面。如果所选渲染器无法在此计算机上启动,会改用其他渲染器,并在页面上给出提示。
3D 页面的右键菜单中有相同的命令:导入模型…、移除模型和减去模型;折叠顺序、设置折叠步骤…(针对所点击的压痕线)、折叠步骤… 和播放步骤;导出校样图像…、导出校样视频…、导出 3D 模型…、导出 3D PDF… 和导出校样 (HTML)…;以及材料。按住右键拖动会旋转视图,而不是打开菜单。
重命名 3D 页面所显示的页面后,3D 页面仍显示该页面。在图纸文件中,3D 页面是一行
PAGE "3D","Page 1","kraft":依次为其名称、所折叠的页面和材料,如有模型和折叠顺序则随后列出(PAGE)。
导出页面
导出时写入当前页面。PDF 或 Illustrator 文件可以包含多个页面:在导出选项中选择 全部 n 页,或选择 页面… 并指定页面(1-3, 5)。每个页面成为 PDF 中的一页(Illustrator 中的一个画板),并以页面名称命名。
图纸文件中的页面
图纸保存时,先写入各页面共享的内容(图层、变量、函数和零件库),然后依次写入每个页面:一行带有其名称的 PAGE、该页面的点,然后是其图元。在交互窗口中输入 PAGE "name" 即可切换到(或新建)该页面。